Forums » Android

Android Gamepads and Joysticks

May 24, 2013 incarnate link
Vendetta Online has supported joysticks and gamepads in Android since the API first became available, but we recently enhanced our support to include full HID support in the default native activity, as well as dynamic joystick detection and some other features. We've also made an effort to have all our tested gamepads and joysticks have decent default mappings for buttons and axes.

Our support on Android includes any device that can be recognized and enumerated by Android, which is not limited to gamepads, but includes full flightsticks (tested) and potentially multi-part controllers (as yet untested).

Our Bluetooth controller support is extensive, at the time of this posting I believe we support every major controller on the market, two of them with proprietary APIs. Bluetooth is extremely convenient for mobile devices, and we hope to see more growth in BT game controllers for mobile.

This thread is intended to give some idea of what joysticks are known to work in Vendetta Online, as well as warn about those known to not work. In some cases, specific revisions of a given joystick may work in Android, while earlier revisions (with older firmware) might not, so please be aware when making purchasing decisions. Some of the devices below are full-sized USB sticks, and were attached on tablets that contain full-sized ports, sometimes through a powered USB hub. Testing was done on Android 4.x.

If you have a device that does not have a full-sized USB port, but want to use a USB joystick, consider checking if the port supports USB On-The-Go, which will be required to make your USB stick be recognized by Android.

Other devices may work than those listed below, this is simply the devices we have tested.

Known Working Controllers, USB / USB-OTG:

Controller Name (model/revision) - Notes.

Logitech Dual Action (G-UD8) - Non-analog L2/R2 show up as buttons L2/R2
Logitech F710 (G-R0001) - Proprietary wireless with USB dongle, enumerated as USB
Logitech Attack 3 (J-UG18) - 3 axis flightstick. Throttle=Z, buttons=JoyButton1-11 (as labeled on the joystick)
Wired X-Box 360 controller (X854237-001) -
Sony PS3 controller (CECHZC2U) - Shows an extra C-Axis and D-Axis that don't seem to do anything. Select=Back, PS3 button=Android Home, square=JoyButtonX, triangle=JoyButtonY, circle=JoyButtonB, cross=JoyButtonA
Gravis Destroyer Xtreme (10512) - 3 axis flightstick. Throttle=Z, buttons=JoyButton1-4
THRUSTMASTER Top Gun Fox 2 Pro (2969048) - 4 axis flightstick with DPad. Twist=Rz, Throttle=Z, buttons=JoyButton1-7 (name has extra spaces)
SAITEK CYBORG 3D Gold USB (J13G) - 4 axis flightstick with DPad. Twist=Rz, Throttle=Z, buttons=JoyButton1-10
Generic Gamestop wired PS3 controller (GameStop 12G4C) - 3rd party wired PS3 controller. Non-analog L2/R2, so only 4 axes are available. Buttons show up as generic buttons: triangle=JoyButton1, circle=JoyButton2, cross=JoyButton3, square=JoyButton4, L1=JoyButton5, R1=JoyButton6, L2=JoyButton7, R2=JoyButton8, Select=JoyButton9, Start=JoyButton10, L3=JoyButton11, R3=JoyButton12, DPad=DPad/left stick. Home button switches mode of the Dpad. Off=Dpad, On=left stick. (off/on state shown by LEDs on the controller)

Known Working Controllers, Bluetooth:

Sony PS3 controller (CECHZC2U) - Same as wired but reports a different name. Needed to plug in with cable to pair this controller
PowerA MOGA Gamepad - Uses Moga Pivot SDK, Select=Back
PowerA MOGA Pro in custom mode(A) - Uses Moga Pivot SDK, Select=Back
PowerA MOGA Pro in HID mode(B) - HID mode, Select=Back
Ouya Game Controller - Double-tap Ouya button for Android Home. Quick-tap for Back
NYKO PLAYPAD PRO (80692-P37) - Home=Android Home, button to the left of Home=Back, button to the right of Home=Start
Green Throttle Atlas - Uses Green Throttle SDK. Shows up in-game as Green Throttle Atlas Player X, where X is 1-4, G button=in-game Home (note, support added but not yet pushed to production release, expected in 06/2013)

Known NOT WORKING Controllers:

Logitech Extreme 3D Pro - Not recognized by Android
Logitech WingMan Force 3D - Not recognized by Android
Saitek Cyborg 3D Force - Not recognized by Android
May 25, 2013 abortretryfail link
I play the game every so often on my Asus TF300T tablet and use this. It works great and folds up to be somewhat portable as far as flight sticks go:

Saitek ST90 - USB stick, 3 buttons, 2 axes with a digital 4-position Z-axis "throttle".
Jun 12, 2013 Korokinopio link
Has anyone had any luck with a wii remote, or the wii classic controller? I haven't tried it, but if I remember, I'll give it a try tonight.
Dec 12, 2015 yodaofborg link
Wii-mote works, but requires a 3rd party app (free, requires the HID enabler app too) on some devices (at least they did on my devices). I did not have the classic controller handy when I tested, but I cannot see it being a problem, as it is basically the same hardware as the wii-mote and nunchuck, just in a differing form factor.
Feb 23, 2016 Kyon Enyif link
I've been hunting for a way to connect my Wiimote to my ZTE Valet, and I found one, but it doesn't carry over to VO. Yodaofborg, I downloaded both applications you posted, but it won't locate my controller. Actually, any of the three that I've tried. Any ideas?
Fri 03:07PM chrono4569 link
hi i am currently playing on the android platform on an invidia shield tv console. i am using the gaming controller that comes with. everything works great with the exception of the activate button. it works for warping only. whenever you need to scan an asteroid to mine or try to dock any ship that doesnt have the auto dock feature it trys to warp, giving me the message "you are already at your destination". i tried using a rii keyboard hooked up to the nvidia shield tv and basically get the same error. if anyone could help it would greatly be appreciated. thanks in advance.